[?+]: Problems with card CP5512 was solved

SIMATIC S7-200/300/400, Step7, PCS7, CFC, SFC, PDM, PLCSIM,
SCL, Graph, SPS-VISU S5/S7, IBHsoftec, LOGO ...
Post Reply
AMB
Posts: 5
Joined: Wed Jun 20, 2007 7:24 pm
Location: Europe

[?+]: Problems with card CP5512 was solved

Post by AMB » Wed Jun 20, 2007 7:50 pm

Hello all.
Can somebody tell me : why is impossible in Simatic Manager Step7 v5.4
to choose CP5512 in "Set PG/PC Interface".
I was installed PC Adapter, TS Adapter and I can choose these interfaces. Why can I choose CP5512?
There is impossible to install this interface in tab "Interfaces-> Add/Remove -> Select...".
What I need to use CP5512? Driver or software?
I use also SIMATIC NET 6.3 and still is no OK

Please help me.

rataman
Posts: 52
Joined: Sat Nov 25, 2006 2:53 am
Location: America

Post by rataman » Wed Jun 20, 2007 9:10 pm

Have you tried to install SP2 to Step 7 and Simatic NET 2006?

http://plc.net.ru/viewtopic.php?t=6168
http://plc.net.ru/viewtopic.php?t=2&pos ... c&start=15

CoMod
Site Admin
Posts: 3975
Joined: Thu Feb 16, 2006 3:25 pm
Location: Russia
Contact:

Post by CoMod » Thu Jun 21, 2007 2:34 am

I use CP5512 without problems.
Install the Step7, and then insert a CP-card in notebook.
Windows itself should find the new device and driver.
The card normally works and without Simatic Net
Installation Simatic Net it is not obligatory.
in Russian wrote:Установи Step7, а затем вставь карту.
Windows сама должна будет найти драйвер.
Карта нормально работает и без Simatic Net
Установка Simatic Net не обязательно.

AMB
Posts: 5
Joined: Wed Jun 20, 2007 7:24 pm
Location: Europe

Problems with CP 5512 ... still

Post by AMB » Fri Jun 22, 2007 11:46 am

Hello
Thanks for links. But stil is problem
I was installed SIMATIC NET 2006 v. 6.4 and next SIMATIC Step7 5.4 SP2 and unfortunately nothing changed. Still is impossible to install in e.g. "Start->SIMATIC->Step7->Set PG/PG Interface" card CP5512(plug&play). In system WinXP with SP2 there is any conflicts with this device. Driver is in C:\WINDOWS\System32\DRIVERS\S7o5512x.sys delivered by SIEMENS AG, version of file: V07.00.00.00_01.10.00.01 release, Copyright (c) SIEMENS AG 2006-2007, but this driver is not written digitally! But I don't thinks that here is problem. Problem is in SIMATIC.
Have somebody any idea ..........????

CoMod
Site Admin
Posts: 3975
Joined: Thu Feb 16, 2006 3:25 pm
Location: Russia
Contact:

Post by CoMod » Fri Jun 22, 2007 12:02 pm


rataman
Posts: 52
Joined: Sat Nov 25, 2006 2:53 am
Location: America

Post by rataman » Sat Jun 23, 2007 1:25 am

It seems to be a hardware problem, some memory area or interrupt is in use by another device.
Try to change address and interrupts, save a hardware profile first.

AMB
Posts: 5
Joined: Wed Jun 20, 2007 7:24 pm
Location: Europe

Problems with card CP5512

Post by AMB » Sun Jun 24, 2007 12:58 pm

Exactly, now I'm sure this is a hardware problem. In my PC interrupt IRQ16 is in use by another devices(USB ports,wireless,SD,MMC card ...). At the same IRQ is also CP5512, but there is impossible to change interrupt for CP5512 from WinXP and from BIOS level. I need special tool to change this interrupt. At the siemens www there is tool only for CP5511 and this tool is not good for CP5512:

http://support.automation.siemens.com/W ... t=standard

Has somebody any idea how to change this interrupt IRQ16 for CP5512 to other number e.g.IRQ5 or IRQ9? Where can be in system non-compiled file to edit it? Maybe i must think contact with supplier of motherboard and upgrade BIOS to have possibility of change IRQ? What somebody who using CP5512 think about this?

rataman
Posts: 52
Joined: Sat Nov 25, 2006 2:53 am
Location: America

Post by rataman » Mon Jun 25, 2007 1:45 am

Can you disable other devices? In BIOS should be a section about integrated devices, maybe disabling LPT or Serial Ports XP will reasign IRQ and memory. Try enabling legacy BIOS or an BIOS update.

AMB
Posts: 5
Joined: Wed Jun 20, 2007 7:24 pm
Location: Europe

Problems with CP 55512

Post by AMB » Tue Jul 03, 2007 8:45 am

Hello all
Problem was solved. I formated drive c: and install WinXP and Step7 again and nothing changed. But when I formatted c: again, disables in BIOS: LAN and WireleesLan and install WinXP and Step7 again was OK.
Card CP5512 normally appears in Set PG/PC Interface. After enabled LAN and WirelessLan in BIOS again is OK. Strange situation, but real and for lucky was solved. Thanks for all messages.

Post Reply