Problems Using Fluidsim and PLSCIM

другие контроллеры
Post Reply
Posts: 1
Joined: Thu Oct 10, 2019 5:17 pm

Problems Using Fluidsim and PLSCIM

Post by seth9008 » Thu Oct 10, 2019 10:28 pm

Hello everyone

I hope you can help me.
I am trying to simulate some very simple things using Plcsim and Fluidsim. I have seen many tutorials, however I cannot make it work.

I am using Tia Portal V14 SP1 on Windows 10, Fluidsim 4.5 and the EzOPC 5.6 server (downloaded from the Festo page). I have configured everything so that the outputs and inputs in the program in Tia Portal match the OPC modules of the Fluidsim, however, when running the simulation in FluidSim I get an error message that says:

Sync Write: OPC Server failed GetErrorString

After that the simulation does nothing, no outputs are activated or anything happens at the inputs.
In the EzOPC window in the PLCSim tab I can see that the outputs are activated (the yellow squares light up) when I force the outputs (QB) in PLSIM, but the inputs do not react at all (and although the EzOPC shows that the outputs are sent correctly nothing happens in the simulation of fluidsim)

I have tried reinstalling previous versions of the EzOPC but I get the same problem.

PD: I tried to simulate everything in a virtual machine with windows 7 and it seems there if it works correctly (with serious performance problems lol)

Does anybody have any suggestions?

PD2: sorry for bad grammar, im using google traslator

Post Reply