[?]: 4 CPU414-2, объединенных по Ethernet-у через CP443

Промышленные Логические Контроллеры SIMATIC S7-200/300/400
Post Reply
danatz
Posts: 32
Joined: Fri Oct 20, 2006 6:35 am
Location: Europe

[?]: 4 CPU414-2, объединенных по Ethernet-у через CP443

Post by danatz » Fri Oct 20, 2006 6:39 am

Такая ситуация: имеется 4 CPU414-2, объединенных по Ethernet-у через CP443.
Каждый CPU сконфигурирован для связи с 3-мя остальными.
Но если посмотреть connection status в NetPro, то получается, что 1-й и 2-й между собой не связываются (сотояние: Is being setup, а в деталях написано, что причина отмены неизвестна и есть различия offline и online).
Причем 1-й нормально связывается с 3-м и 4-м, а также 2-й с 3-м и 4-м.
Конфигурацию всех соединений сравнивал -все сделано аналогично. Сама конфигурация загружена из CPU.
Помогите советом.

sania
Site Admin
Posts: 1139
Joined: Sat Aug 13, 2005 6:15 am

Post by sania » Fri Oct 20, 2006 7:16 am

смотри диаг.буфер СР.чё он пишет?
ставил ли какие-нибудь галочки в свойствах ЦПУ,делал ли изменения в нетпро?
сделай компиляцию соединений и загрузи их в каждый ЦПУ

---------------------------------------------------------------------
а воще если хочешь чтоб помогли,а не спрашивали очевидные вещи,то исповедоваться надо,батенька :D

чё ваще делал с поектом?где исходник?если делал аплоад,то потом руками засовывал всё в один проект или лежит в разных?как связи обозначены,есть ли в них абсолютное указание на соответствующий ЦПУ или "анспецифет"?после этого грузил или нет в контроллеры?

danatz
Posts: 32
Joined: Fri Oct 20, 2006 6:35 am
Location: Europe

Post by danatz » Fri Oct 20, 2006 9:15 am

С проектом вроде бы ничего не делал, исходник на руках есть, после аплоада все лежит в отдедьных проектах -на каждый CPU, связи обозначены как Unspecified, после аплоада в CPU ничего не грузил.
После компиляции исходников -ошибок нет. После компиляции аплоад проектов появляется предупреждение: Warning "S7 connection ID 2 (для всех 4-х ID): For this uploaded connection, there is no need for function "Compile" and "Load PLC" because the connection was still not modified after upload the programming device.
В свойствах ЦПУ ничего не добавлял в нет про изменений не делал.
В диагностич. буфере ничего конкретного для этого соединения:
в 1-м CP после рестарта:
Event 2 of 14: Event ID 16# F9C1:0255
Netinterface: Automatic setting, AUI with 10 Mbps half duplex
External error, Incoming event

Event 3 of 14: Event ID 16# F9C1:061C
The time of day on the module is synchronized over the communication bus.
External error, Incoming event

во 2-м, который является активным -тоже самое, а затем идут ошибки:
Event 15 of 30: Event ID 16# F9C1:260D
Connection 21 is not established.
External error, Incoming event

Event 16 of 30: Event ID 16# F9C1:260D
Connection 20 is not established.
External error, Incoming event

Connection 20,21 -это ISO-on-TCP сonnection и физически отсутствует.

sania
Site Admin
Posts: 1139
Joined: Sat Aug 13, 2005 6:15 am

Post by sania » Fri Oct 20, 2006 11:41 am

чёт не пойму:зачем работать с аплоадом если есть исходник?
в нём все станции вместе?
сделай аплоад со станций,сохрани их без изменений(на случай аварийного восстановления).
открой исходник,связи,ОДИН раз нажми сохранить_и_скомпилировать.
загрузи связи по очереди во все ЦПУ.
зайди в онлайн и проверь состояние связи.

Post Reply