plcforum.uz.ua

International PLC Forum
It is currently Mon Sep 24, 2018 10:40 pm

All times are UTC + 3 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: ControlNET problem
PostPosted: Sun Jul 26, 2015 8:38 pm 

Joined: Tue Aug 14, 2012 10:34 pm
Posts: 4
Добрый день. Надеюсь моя тема не останется от ответа.
Опишу ситуацию: Есть резервированная система. Удаленные шасси подключены по оптике. RSNetWorx сконфигурирован согласно проекта (длина кабелей + модуля повторители). Периодически происходит сбой сети, в результате потеря узла(ов) сети. В диагностических счетчиках приходят ошибки по обоим линиям (А и В), а так же потеря пакетов. Это явление кратковременное. На случайных модуле(ях) CN2R(1794-ACNR) возникает ошибка "Duplicate Node detected". Иногда отказывает резервирование. В логе модуля RM2 пишет, что отсоединен кабель от модуля CN2R в резервном шасси или ошибка в программе. Второй вариант исключен, систему оставляли в режиме "Stop" на ночь - утром получили потерю двух узлов. Резервирование исправно и работает(переходит на резерв и восстанавливается). Проверили оптику, затухание в пределах нормы. Проверил модуля RPFRXL на последнюю прошивку, все 2.005.
Система распределенная и почти все узлы подключены по оптике. Игрался с настройками в RSNetworx (Media Configuration). Конфигурация сети: RPI модулей 80ms. NUT сети 20ms. Всего узлов 25.


0 - L74/B 19.53 (до этого была 20.55)
1 - RM2/A 20.005
2 - CN2R/B 20.13
3 - CN2R/B 20.13
4 - EN2T/C - 10.7
5 - EN2T/D - 10.7
6 - EN2T/D - 10.7

http://my-files.ru/ohe75o - ControlNET


Top
 Profile  
 
 Post subject: Re: ControlNET problem
PostPosted: Mon Jul 27, 2015 2:58 pm 

Joined: Wed Apr 30, 2014 9:16 pm
Posts: 81
According to Rockwell's Product Compatibility & Download page, cpu L74 version 19 is not compatible with redundancy:

http://compatibility.rockwellautomation ... 2405,52406

You need to upgrade the CPU's firmware to 20.055.

Are you sure there is an EN2T/C with firmware 10.7 in your configuration? So far I read, EN2T series C only has version 5.

Some questions:
a) Is this system new or old? I mean, if this system is a new design it`s necessary to check many things. If this system is working for years without problems, you need to check for recently changes on hardware and software.
b) Are you using ALMA and ALMD blocks? In redundancy there is a limit of blocks you can use.


Top
 Profile  
 
 Post subject: Re: ControlNET problem
PostPosted: Mon Jul 27, 2015 8:07 pm 

Joined: Tue Aug 14, 2012 10:34 pm
Posts: 4
Спасибо. Система новая. Изначально ПЛК был версией 20.55, столкнулись с проблемой и заказчик попросил прошить на 19.53, так как все контроллеры на объекте 19 версии. Прошу прощения , модуля EN2T/D версии 10.007.
Нет, я не использую блоки ALMA и ALMD вообще.
Сегодня обнаружили интересную вещь, по одной линии А нормально система работает. A по линии B происходит сбой, так что вызывает ошибку в узлах сети ContolNET ("Duplicate node detected"). Проверяли оптический кабель связи - был грязный коннектор - устранили. Но затухание по оптике в пределах нормы.


Top
 Profile  
 
 Post subject: Re: ControlNET problem
PostPosted: Tue Jul 28, 2015 12:18 am 

Joined: Wed Apr 30, 2014 9:16 pm
Posts: 81
I undestand that the problem is solved, right?

In any case, about the cpu's firmware, please read the following document:

http://literature.rockwellautomation.co ... _-en-p.pdf

In page 3 and 4 you will find the Required Series and Firmware Revisions for Components. You can check your system using those tables.


Top
 Profile  
 
 Post subject: Re: ControlNET problem
PostPosted: Wed Jul 29, 2015 7:51 pm 

Joined: Tue Aug 14, 2012 10:34 pm
Posts: 4
Да, проблема оказалась в оптическом кабеле, точнее в коннекторах, они были грязные. (Приехал специалист и с помощью специального оборудования подтвердил и почистил их)


Top
 Profile  
 
 Post subject: Re: ControlNET problem
PostPosted: Thu Jul 30, 2015 7:29 pm 

Joined: Tue Aug 14, 2012 10:34 pm
Posts: 4
Thank you for your help. The problem was solved, it was in the optical cable. More precisely in the connector. The attenuation in the normal range, but through a microscope - seen strong contamination. Well, that was found specialist equipment at the facility.

P.S.Topik can be closed.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 3 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by International PLCforum® Forum Software © PLCforum
Mobile version