plcforum.uz.ua

International PLC Forum
It is currently Wed Mar 29, 2017 4:18 pm

All times are UTC + 3 hours


Forum rules


Please click here to view the forum rules



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Dec 26, 2015 7:56 pm 

Joined: Mon Sep 27, 2010 10:17 pm
Posts: 30
Всем привет !
С наступающим Happy New Year !!!

Он будет более радостным, если удастся решить небольшую проблемку.

Имеется система АСУТП на базе SIEMENS, а именно PLC S7-300 и PC c WinCC, в качестве визуализации. Связь между ними осуществляется по сети Industrial Ethernet. В контроллере для этой цели используется дополнительный модуль CP 343-1 Lean (6GK7 343-1CX10-0XE0 v2.2).
В настройках данного модуля, в "NetPro", указан его IP адрес.
Там же, в "NetPro", в настройках связи для РС Station указан её IP адрес. МАС- адрес не активирован и не используется.

Но в настройках WinCC- проекта соединение в "Tag Managment" - "Simatic S7 Protocol Suite" создано не через "Industrial Ethernet", "Industrial Ethernet (II)" или "TCP/IP", а через "Named Connections", т.к., со слов наладчика, который всё это конфигурировал, ONLINE-connection между PLC и PC удалось добиться только через "Named Connection".
Тем не менее всё заработало, но позже возникла необходимость добавить ещё один РС в качестве АРМ-2.
Я установил на него WinCC, скопировал туда рабочий WinCC- проект, запустил WinCC RT, но все Output Fields на экранах оказались, увы, безжизненными.
Т.е. значения тэгов от ПЛК на РС не передавались.

Есть мнение, что из-за того, что ранее в WinCC- проекте, в папке "Simatic S7 Protocol Suite", было выбрано "Named Connections", то чтобы мне добиться желаемого, необходимо в "Network Pro Config" котроллера добавить новый элемент (PC Station-2), аналогичный тому что уже был создан для АРМ-1 и перезагрузить в ПЛК обновлённую конфигурацию.

Так ли это или что нужно сделать ?

Заранее благодарен.


Top
 Profile  
 
PostPosted: Sun Dec 27, 2015 4:17 pm 

Joined: Wed Oct 13, 2010 11:44 am
Posts: 125
Location: Russian Federation
Достаточно странная ситуация, что TCP и ISO соединения в WiCC не заработали. И, я боюсь, добавление 2-й OS и создание еще одного Named Connection в NetPro ничего не даст. Соединение-то установится, но вот программа в контроллере сделана только для одного (первого) соединения, и во вновь созданное ничего слать не будет. I/O Field'ы в 2-м WinCC конечно станут белыми, но всегда будут нулевыми.
Шанс один - заставить работать TCP или ISO с 1-й станцией, а затем и со 2-й. Копайте HWConfig контроллера, в частности его комуникационника.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 3 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by International PLCforum® Forum Software © PLCforum
Mobile version