Search found 50 matches

by nashama
Thu Jun 27, 2013 11:47 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

Dear almaz78, Actually, it was my misunderstanding with the occurence of OB35. By default it comes every 100ms which means M1.0 will stay on for 100ms and off for another 100ms and so on (thanks for your advice as well in your 2nd last post). That means M1.0 will have a rising edge every 200ms and a...
by nashama
Tue Jun 25, 2013 2:32 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

Dear almaz78, Will try those codes & get back to you. Yes, CPU Clock mem is an option for this kind of application .........but ....... I's just curious to dig more on the existing codes !! What is your opinion in such a situation - is it better to use OB3x or better to use CPU Clock pulses? which o...
by nashama
Mon Jun 24, 2013 2:13 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

And just noticed, there's a missing part after that FP M1.1.

A M1.0
FP M1.1
JCN NEXT
L DB1.DBD0 // ZAHLER
+ L#1
T DB1.DBD0 // ZAHLER
L 100 //bold letters
<>I
JC NEXT
L DB1.DBD4 // DISPLAY SECONDS
+ L#1
T DB1.DBD4 // DISPLAY SECONDS
L 0
T DB1.DBD0 // ZAHLER

NEXT: NOP 0
by nashama
Mon Jun 24, 2013 1:45 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

Besides, my undertsanding was that M1.0 will come true avery 100ms even though the codes are written in FC1.

Regards
by nashama
Mon Jun 24, 2013 1:43 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

Thanks again.

But then what is the rationale behind that 100?

How come it gives correct results with 100 even though FC1 is called from OB1 and not in OB35??

rEGARDS
by nashama
Mon Jun 24, 2013 11:40 am
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

Re: [?]: OB35 - 100ms

Thanks for the reply.

FC1 is not called from OB35.

It is called from OB1 only.

Is that the error?

Regards
by nashama
Sun Jun 23, 2013 7:57 pm
Forum: SIMATIC system
Topic: [?]: OB35 - 100ms
Replies: 10
Views: 3983

[?]: OB35 - 100ms

Hello, The following codes are meant to display time in seconds using OB35. OB35: AN M1.0 = M1.0 FC1: A M1.0 FP M1.1 L DB1.DBD0 // ZAHLER + L#1 T DB1.DBD0 // ZAHLER L 100 //[b]bold letters[/b] <>I JC NEXT L DB1.DBD4 // DISPLAY SECONDS + L#1 T DB1.DBD4 // DISPLAY SECONDS L 0 T DB1.DBD0 // ZAHLER NEXT...
by nashama
Thu Oct 25, 2012 9:53 pm
Forum: SIMATIC system
Topic: [?]: how copy FCs from s7 project ?
Replies: 5
Views: 3507

Re: [?]: how copy FCs from s7 project ?

You mean a subprogram within the existing programs?
by nashama
Fri Oct 19, 2012 3:11 pm
Forum: SIMATIC system
Topic: [?]: how copy FCs from s7 project ?
Replies: 5
Views: 3507

Re: [?]: how copy FCs from s7 project ?

I shall do so dear deltafox1002.

Regards
by nashama
Tue Oct 16, 2012 4:00 am
Forum: SIMATIC system
Topic: [?]: how copy FCs from s7 project ?
Replies: 5
Views: 3507

[?]: how copy FCs from s7 project ?

Hello, I have one s7 project with many FCs in it. I created this project few years ago (not for a real machine but for practice purpose only). Now I want to separate each function and make a separate project of that function. May I know what is the easiest procedure to do this? I'm using step7 V5.5 ...
by nashama
Sat Oct 13, 2012 12:52 am
Forum: SIMATIC system
Topic: Installing Step7 V5.5 SP1 and WinCC Flex 2008 SP3 on Win7?
Replies: 3
Views: 6384

Re: Installing Step7 V5.5 SP1 and WinCC Flex 2008 SP3 on Win

Thank you very much for the link. Infact, you enabled me to upgrade from s7 V5.5 SP1 to s7 V5.5 SP2. Not just that, I also got Step7 professional 2010 SR2 !! This site is just wonderful and possesses a wealth of info on Simatic products. Just a small request if someone on the forum can personally co...
by nashama
Wed Oct 10, 2012 6:33 pm
Forum: SIMATIC system
Topic: Installing Step7 V5.5 SP1 and WinCC Flex 2008 SP3 on Win7?
Replies: 3
Views: 6384

Installing Step7 V5.5 SP1 and WinCC Flex 2008 SP3 on Win7?

Dear Forum members, Could someone confirm if Step7 V5.5 SP1 and WinCC Flex 2008 SP3 can be installed on Windows7 professional 64-bit or Windows7 Ultimate 64-bit? (I just bought a new laptop but it has Win7 Home premium 64-bit. I'm planning to make recovery DVDs and the replace the Win7 Home premium ...
by nashama
Mon Oct 01, 2012 1:28 am
Forum: SIMATIC system
Topic: [?]: Pointer Information
Replies: 3
Views: 4316

Re: [?]: Pointer Information

Thank you zigouiik, LargoD, delege.

Good explanation.

Regards
by nashama
Wed Jan 04, 2012 6:16 am
Forum: SIMATIC system
Topic: [?]: Sourcing / Sinking I/O Modules with PNP/NPN transistors
Replies: 1
Views: 1338

[?]: Sourcing / Sinking I/O Modules with PNP/NPN transistors

Hello ! http://support.automation.siemens.com/WW/llisapi.dll?query=sourcing+sinking+inputs+outputs&func=cslib.cssearch&content=adsearch%2Fadsearch.aspx&lang=en&siteid=cseus&objaction=cssearch&searchinprim=0&nodeid0=10805384 The above link shows the SIMATIC Modules wiring configuration for sourcing a...
by nashama
Thu Dec 29, 2011 5:38 pm
Forum: SIMATIC system
Topic: [?]: Hydraulic Pump and Valve
Replies: 9
Views: 3489

Re: [?]: Hydraulic Pump and Valve

Thank you very much for the response.
by nashama
Fri Dec 16, 2011 8:26 am
Forum: SIMATIC system
Topic: [?]: Hydraulic Pump and Valve
Replies: 9
Views: 3489

Re: Hydraulic Pump and Valve

@ Homeroid_BL : "Pump should run continously." But the pushing event takes place every 30min (or least 15min) ..... Is it advisable to keep the pump running? I mean why can't we engage the pump when the pushing time is up and ofcourse after 1s energize the valve as well? 1s is not enough to build up...
by nashama
Thu Dec 15, 2011 9:39 pm
Forum: SIMATIC system
Topic: [?]: Hydraulic Pump and Valve
Replies: 9
Views: 3489

Re: Hydraulic Pump and Valve

@ PLC_ITA: " ............. , and then open the valve"

1s will be good enough?
Regards
by nashama
Thu Dec 15, 2011 7:31 pm
Forum: SIMATIC system
Topic: [?]: Hydraulic Pump and Valve
Replies: 9
Views: 3489

[?]: Hydraulic Pump and Valve

Hello ! In a simple hydraulic application the cylinder moves forward / backward, what is the usual practice in programming (S7) - Is the pump and valve activated together or a certain delay is to be observed before engaging the valve? Like , is it ok to command "Q2.0" (HYDRAULIC PUMP) and "Q2.1" (VA...
by nashama
Fri Sep 30, 2011 1:24 am
Forum: SIMATIC system
Topic: [?]: SP1 For S7 V5.5
Replies: 0
Views: 2337

[?]: SP1 For S7 V5.5

Dear Members, The 1st service pack for Step7 V5.5 is now available from Siemens. Can I directly install it on my PC which already has S7 V5.5 which was downloaded from the web? My concern is what if Siemens has delivered this SP1 installation which will check for the authentication / legality of the...
by nashama
Sat Sep 17, 2011 10:22 am
Forum: SIMATIC HMI
Topic: [?]: Time display in WinCC Flex 2008
Replies: 1
Views: 2205

[?]: Time display in WinCC Flex 2008

Dear experts, I used FC33 (s5time to IEC Time) to display the time interval set by the operator for a cyclic event (like for e.g turning of a Turn Table which turns after a specific time set by the operator which is stored in one of the data bloc , say DB1.DBW2 , declared as S5Time). There are 2 dis...
by nashama
Thu Sep 08, 2011 12:40 pm
Forum: SIMATIC HMI
Topic: [?]: WinCC Flex 2008 - Order of installation?
Replies: 1
Views: 3092

[?]: WinCC Flex 2008 - Order of installation?

Dear All, From the below list , What should be the order of installation after installing WinCC Flex 2008? 1) Wincc Flex 2008_SP2 2) Wincc Flex 2008_SP2_UPD 13 3) Wincc Flex 2008_HF3 And one more thing - I remember when I was having WinCC Flex 2005, I found my RAM memory is considerably utilized whe...
by nashama
Tue Aug 09, 2011 11:15 am
Forum: SIMATIC HMI
Topic: ?:Safety when Manual-Automatic selection is from 2 locations
Replies: 5
Views: 2445

Re: ?:Safety when Manual-Automatic selection is from 2 locat

Dear bilbo_321,
Thanks again for your time and attention.
I modified something in the network that selects / interlocks between the panel's Man-Auto and the TP177's Man-Auto and it is based on your 2nd post (the corrected one).
But I don't see any means to attach the screenshots here.
Regards
by nashama
Mon Aug 08, 2011 3:45 pm
Forum: SIMATIC HMI
Topic: ?:Safety when Manual-Automatic selection is from 2 locations
Replies: 5
Views: 2445

Re: ?:Safety when Manual-Automatic selection is from 2 locat

Dear bilbo_321, Thanks for the reply. When you say " ......... if manual mode is detected from selector switch at the panel, then you should prohibit selecting automatic mode from HMI (or SCADA). The idea is if somebody is working at field and has selected manual mode, you should never enable automa...
by nashama
Sat Aug 06, 2011 6:42 pm
Forum: SIMATIC HMI
Topic: ?:Safety when Manual-Automatic selection is from 2 locations
Replies: 5
Views: 2445

?:Safety when Manual-Automatic selection is from 2 locations

Dear All, Consider a selector switch is located at the electrical panel and it is wired to the PLC at I0.5 (When I0.5 is low = Manual , when I0.5= high = Auto). Also, WinCC has configured the touch panel with a button authorizing selection of Manual and Automatic. How to make sure the safety? Just b...
by nashama
Tue Jun 28, 2011 4:02 pm
Forum: SIMATIC HMI
Topic: [?]: sample projects for WinCC Flex 2005
Replies: 4
Views: 3485

Re: [?]: sample projects for WinCC Flex 2005

Dear Info, Thank you very much for the link. I was able to "put them together" after following those instructions. Infact , I simulated a small program of Motor start-stop on it. Additionally, can you advise me on how to close the WinCC Flex RT window? Is it ok to click the "X" (close window) or the...
by nashama
Thu Jun 23, 2011 12:48 pm
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

So, the way I downloaded will not sit on Windows XP SP3?
According to the above download variants, I guess I made a mistake in the order of the downloading.
Please advise.
Regards
by nashama
Wed Jun 22, 2011 9:40 am
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

I have Windows XP SP3.
I got Wincc flex 2008 from narod.ru (not rapidshare !!)
SP2 from Siemens website and HF13 also from Siemens website !
Please advise.
by nashama
Wed Jun 22, 2011 9:07 am
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

Dear CoMod,

You mean I can install SP2 without installing SP1?

And , the link you gave me talks about HF3 , HF2 and HF1.

Can I install HF3 without installing HF2 and HF1 ?

Please confirm.

Many thanks for positive co-operation.

REGARDS
by nashama
Wed Jun 22, 2011 2:22 am
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

Dear CoMod, As you siad : " http://www.plcforum.uz.ua/viewtopic.php?f=36&t=8650 WinCC Flexible 2008 with SP2 Full DVD 3.6 GB ISO image " After I unpacked all the 12 zipped files , it created a new folder "Winccflex 2008" of just 2.40GB (not 3.6GB as you said). May I know if Anything wrong in my down...
by nashama
Mon Jun 20, 2011 3:01 pm
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

Dear CoMod, Thank you very much for the quick response and the setup file for Winrar ! Rapidshare puts me on hold for 5 min and then says something like "server connection not reachable or switch to premium account". I tried with narod.ru, It is asking for, probably, an activex or some permission to...
by nashama
Mon Jun 20, 2011 1:50 pm
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

Hi ! Many thanks for the info/link. I will install a "comparable"' device OP77B and then try again. Actually, I made a very simple program of a motor start-stop (only one FC !) and tested on S7-PLCSIM. It works. But I was hoping to see some kind of "animation" on the WinCC Flex screen ........ somet...
by nashama
Mon Jun 20, 2011 10:58 am
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

Re: [?]: simulation between s7plcsim + step7+wincc flex 2005

Hello ! My PG/PC interface is set to PLCSIM(MPI) as I confirmed it from Simatic Manager. The HMI I'm using in WinCC Flex is OP73 . I downloaded the project to S7-PLCSIM and everything gets simulated successfully ok. But when I try to start runtime simulator from WinCC Flex , it says something like ....
by nashama
Fri Jun 17, 2011 2:57 pm
Forum: SIMATIC system
Topic: [?]: simulation between s7plcsim + step7+wincc flex 2005
Replies: 13
Views: 14798

[?]: simulation between s7plcsim + step7+wincc flex 2005

Hello ! A simple program of start - stop motor is to be simulated between step7 + S7-PLCSIM + WinCC Flex 2005. Could anyone please give a simple procedure of how to configure these 3 applications (already installed on one laptop) and see the visuals on WinCC Flex screen (like say a conveyor is runni...
by nashama
Mon Jun 13, 2011 5:30 pm
Forum: SIMATIC HMI
Topic: [?]: sample projects for WinCC Flex 2005
Replies: 4
Views: 3485

Re: [?]: sample projects for WinCC Flex 2005

Dear Info, Thanks for the reply. I retrieved those projects from the folder you suggested. But I cannot download the files from rapidshare ... it asks me to wait for 5min and then says something like "....could not find connection to the server ...". Just 1 request - How do I connect these 3 applica...
by nashama
Sun Jun 12, 2011 3:07 pm
Forum: SIMATIC HMI
Topic: [?]: sample projects for WinCC Flex 2005
Replies: 4
Views: 3485

[?]: sample projects for WinCC Flex 2005

Dear forum members,

Could you please suggest me where to get some sample projects for WinCC Flex 2005?

Regards
by nashama
Sun Jun 05, 2011 12:27 am
Forum: SIMATIC system
Topic: [?]: Detect failure of Encoder counts
Replies: 5
Views: 2605

Re: [?]: Detect failure of Encoder counts

Dear Scarch,

You are correct.

It is better to have to have a threshold value (like 50.0 as a tolerable margin) before you raise the alarm.

Regards
by nashama
Thu Jun 02, 2011 9:00 am
Forum: SIMATIC system
Topic: [?]: Detect failure of Encoder counts
Replies: 5
Views: 2605

Re: [?]: Detect failure of Encoder counts

Dear Peterg70 and Scarch, Thanks for your time and attention. Also, many thanks for the idea. How about trying the following codes in OB35. A Q 3.2 "MACHINE LIFTING FP M 6.1 R M 6.0 "ENCODER ALARM" JU P1 P1: A Q 3.2 "MACHINE LIFTING" JCN P2 L "DATA B".encoder_value "ACTUAL ENCODER VALUE" L "DATA B"....
by nashama
Thu May 26, 2011 8:43 am
Forum: SIMATIC system
Topic: [?]: Detect failure of Encoder counts
Replies: 5
Views: 2605

[?]: Detect failure of Encoder counts

Dear All, L PIW 256 T DB10.DBD26 PIW 256 is the hardware address of the Encoder mounted on the travel drive of a machine. What are the possible ways to detect if this Encoder is not generating any signals (like a warning display on the HMI that Encoder is not responding to the movement of the machin...
by nashama
Thu May 19, 2011 3:05 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Thanks pwkoller. So my idea of time resolution (or time base of S5timer) versus scan cycle time of CPU is not the reason of the problem as Sventek clarified that timers run asynchronously to the user program. Further to that , I take your advice to make sure the signal state is made to last more tha...
by nashama
Wed May 18, 2011 2:20 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear pwkoller, Thanks for suggesting another way to set M100.0 pwkoller : "Anyway : i can not imagine any practical use of accumulating times this way" That's right. It is just for testing purpose only ....... Though it looks so simple to the naked eye , for the first time when you see the codes tha...
by nashama
Mon May 16, 2011 1:31 am
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear Trafo, Thanks for the reply. May I ask u few things? 1) Why can't you use " + I " instead of " +D " to increment MW1000 since it is a WORD, not a DOUBLE WORD. 2) Trafo : "The reason why I called SIEMENS folklore, so you get used to it." Couldn't understand that ......... is it some kind of myst...
by nashama
Mon May 16, 2011 1:19 am
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear Sventek,

Counter C5 did not count at all.
I had to modify the codes (which is more or less similar to Trafo's suggessions)

AN M4.6
L S5T#1s
SD T5

A T5
= M4.6
CU C5

With this arrangement , C5 started counting.
Regards
by nashama
Mon May 16, 2011 1:12 am
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear SHKODRAN,

You demonstrated another way of HOW to set M100.0 , while I was asking for the reason WHY M100.0 was not getting set in my original post.
Nevertheless, thank u for sharing the new idea to set M100.0.
Regards
by nashama
Sat May 14, 2011 6:24 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Thanks again dear Sventek. In context of this thread , I found something in your explanation which I couldn't find even through "F1" of Simatic Manager. Thank u. How about this?(hope you will respond with an equally interesting reply) AN T5 L S5T#1s SD T5 A T5 CU C5 Will C5 keep counting? or this si...
by nashama
Fri May 13, 2011 6:18 pm
Forum: SIMATIC system
Topic: New address - plcforum.uz.ua, select forum English language
Replies: 19
Views: 91583

Re: New address - plcforum.uz.ua, select forum English langu

Welcome back.
Keep up the goodwork.
All the best to this website and the moderators for their professional commitment and dedication.
by nashama
Fri May 13, 2011 3:40 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear sventek, Many thanks for the reply. Definitely, u gave the insight of the s7 STL codes (Thx again !) My estimate was this (which may be wrong):Since the timers are updated every 10ms, the scan of CPU may not be able to set M100.0 immediately below the original codes. However, when the last 2 st...
by nashama
Fri May 13, 2011 2:11 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear hardy,
Just 1 more thing with respect to your modified codes:
I haven't simulated your codes yet ......... but do you mean M100.0 will get set after 10s ?
Plz comment back.
Regards
by nashama
Fri May 13, 2011 2:02 pm
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

Re: [? Code]: What is the reason for M100.0 not being set?

Dear hardy,

Thanks for the reply.
I will try your codes on simulator (and with all due respect I know it will work)
But I just wanted to know what is the EXACT reason for M100.0 for not getting set in my original codes.
In short, can u explain in words , why it doesn't get set?
Regards
by nashama
Fri May 06, 2011 11:29 am
Forum: SIMATIC system
Topic: [? Code]: What is the reason for M100.0 not being set?
Replies: 18
Views: 7736

[? Code]: What is the reason for M100.0 not being set?

Dear All,

Code: Select all

AN T10
L S5T#5S
SD T11

A T11
L S5T#5S
SD T10

A T10 
S M100.0
What is the exact reason for M100.0 for NOT getting set?

And why/what difference will it make , if we shift the last 2 statements on top of the codes?

Regards
by nashama
Fri Apr 29, 2011 2:47 pm
Forum: SIMATIC system
Topic: [?]: s7-200 simulator connection problem
Replies: 4
Views: 3241

Re: [?]: s7-200 simulator connection problem

Dear Homeroid_BL, Thanks for your response (and sorry for the delayed reply from my side which was due to some issues with my registration and I sincerely thank the Moderators /Administrators for their professional assistance) I'm using s7-200 version 2.0 downloaded from http://personales.ya.com/can...